Yes, the SymplySPARK is compatible with the latest M1, M1 Pro and M1 Max based Mac hardware.  Please download the latest driver [here]


If you have any questions please submit a [support ticket]